Formats and Software

The Noiiz Plugin comes in VST, AU and AAX formats and aims to support the latest versions of all major DAWs including but not limited to...

  • Ableton Live
  • FL Studio
  • Logic Pro X
  • Pro Tools
  • Reaper
  • Studio One
  • Cubase
  • Reason

System Requirements

For the Noiiz Plugin to run at optimum performance, you'll need your computer to match the following requirements...

  • Mac OSX 10.9 or above, or...
  • PC Windows 7 (SP1) or above with IE 11 installed.
  • 2.4GHz dual-core CPU or higher
  • 512MB RAM or higher
  • Minimum 1GB of disk space
  • Internet connection of 1Mbps or higher
  • Software installed that loads VST, AU or AAX plugin formats (see above)

For information on how to install, check out these two articles

More info:

To find out more about the Noiiz plugin click here.

If you have any questions about compatibility or system requirements, please don't hesitate to get in touch!

Did this answer your question?